25.1.16

CCNA VOICE Lab Manual: Establishing Network Connectivity and Understanding IP Phone Registration

In both Cisco Unified Communications Manager Express (CUCME) and Cisco Unified Communications Manager (CUCM) environments, phones need to connect to the network to receive services such as IP addresses from DHCP, VLAN assignments for voice traffic, IP information on where to register, and Network Time Protocol (NTP) packets. This chapter focuses on establishing those services.
In this chapter, you will set up a voice network for the fictitious company Shiny Objects Incorporated (SOI). Before phones are connected, you must establish network connectivity and configure needed services.

Lab 3-1: Network Connectivity

Equipment Required
This lab uses the following equipment:
  • Cisco router
  • Switch that supports voice VLANs
  • PC for testing
  • Cisco IP Phone (optional, but useful if switch supports Power over Ethernet [PoE])
Learning Objectives
Upon completion of this lab, you will be able to
  • Perform basic router and switch configuration
  • Configure VLANs to support data, voice, and network management traffic
  • Configure VLAN trunking between a router and a switch using subinterfaces
  • Configure router-based DHCP pools for voice and data devices
Scenario
SOI would like to establish its new data network with the expectation of using VoIP in the near future.
These instructions refer to the Pod Addressing Table in Appendix A to determine the IP addresses and VLAN numbers used for your pod. Wherever an x is shown, substitute the pod number.

Task 1: Clear and Cable Devices

Because the CCNA is a prerequisite for the CCNA-Voice certification exam, this book assumes that you are familiar with clearing prior configurations.

Step 1-1: Clear Prior Configurations

Clear any prior configuration on the router and switch, and delete the vlan.dat file before reloading both devices.

Step 1-2: Cable Router and Switch

Cable router interface Fast Ethernet 0/0 to switch port Fast Ethernet 0/1, as shown inFigure 3-1. The PC will be connected later.
Figure 3-1
Figure 3-1. Topology Diagram

Task 2: Configure Basic Setup

This task establishes the basic configuration commands on both the router and switch.

Step 2-1: Configure Basic Setup on the Router

Router(config)# hostname RtrPodx
For example, Pod 8 would use hostname RtrPod8.
RtrPodx(config)# no ip domain-lookup
RtrPodx(config)# enable secret class
RtrPodx(config)# line con 0
RtrPodx(config-line)# logging synchronous
RtrPodx(config-line)# exec-timeout 120 0
RtrPodx(config-line)# password cisco
RtrPodx(config-line)# login
RtrPodx(config-line)# line vty 0 15
RtrPodx(config-line)# password cisco
RtrPodx(config-line)# login
RtrPodx(config-line)# exit

Step 2-2: Configure Basic Setup on the Switch

Switch(config)# hostname SwPodx
For example, Pod 3 would use hostname SwPod3
SwPodx(config)# no ip domain-lookup
SwPodx(config)# enable secret class
SwPodx(config)# line con 0
SwPodx(config-line)# logging synchronous
SwPodx(config-line)# exec-timeout 120 0
SwPodx(config-line)# password cisco
SwPodx(config-line)# login
SwPodx(config-line)# line vty 0 15
SwPodx(config-line)# password cisco
SwPodx(config-line)# login
SwPodx(config-line)# exit

Task 3: Configure the Switch

For the purposes of security and ease of implementing quality of service (QoS), use VLANs to keep voice traffic separate from other traffic.

Step 3-1: Create the VLANs

Create and name VLANs for data, voice, and network management.
SwPodx(config)# vlan x0
SwPodx(config-vlan)# name Data
SwPodx(config-vlan)# vlan x1
SwPodx(config-vlan)# name Management
SwPodx(config-vlan)# vlan x5
SwPodx(config-vlan)# name Voice
SwPodx(config-vlan)# exit

Step 3-2: Configure the Trunk Port

Configure the trunk port that connects the switch to the router. Layer 3 switches (such as the Cisco Catalyst 3560) require that the trunking protocol be specified with the switchport trunk encapsulation command before the interface can be set as a trunk. If you are using a Layer 2 switch (such as a Cisco Catalyst 2950 or 2960), the command is not needed and will be rejected.
SwPodx(config)# interface fastethernet 0/1
SwPodx(config-if)# switchport trunk encapsulation dot1q
SwPodx(config-if)# switchport mode trunk
SwPodx(config-if)# exit

Step 3-3: Configure the Access Ports

Almost all Cisco IP Phones are designed with a three-port switch built inside (one physical port connected to the production switch, one physical port for a PC to connect to the phone, and one internal port for the phone itself). This built-in switch saves money in wiring costs, as existing phone cabling might not meet networking standards. This enables an existing computer to be plugged into the phone, and the phone connects to the switch in the wiring closet.
Prior to the introduction of voice VLANs, a trunk connected an IP Phone to the switch to keep the voice and data traffic separate. Current best practice configures the ports connected to phones and PCs to use access mode but adds a secondary voice VLAN. The switch ports use the access VLAN to send data traffic as untagged frames. However, if the switch detects a Cisco IP Phone using Cisco Discovery Protocol (CDP), it will inform the phone of the VLAN used for voice traffic, which will be tagged using 802.1q. This creates a pseudotrunk that allows only the data and voice VLANs on the link.
Use the interface range command to assign settings. This is the fastest way to assign settings to more than one switch port at a time.
SwPodx(config)# interface range fastethernet 0/2 – 24
SwPodx(config-if-range)# switchport mode access
SwPodx(config-if-range)# switchport access vlan x0
SwPodx(config-if-range)# switchport voice vlan x5
SwPodx(config-if-range)# exit

Example 3-1. Verify That spanning-tree portfast Is Created by the Voice VLAN Assignment

SwPod11# show run



interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/2
 switchport access vlan 110
 switchport mode access
 switchport voice vlan 115
 spanning-tree portfast


Step 3-4: Configure the Switch Management Interface

Set up an interface to manage the switch remotely.
SwPodx(config)# interface vlan x1
SwPodx(config-if)# ip address 10.x1.0.2 255.255.255.0
SwPodx(config-if)# exit
SwPodx(config)# ip default-gateway 10.x1.0.1

Task 4: Configure the Router Subinterfaces

Subinterfaces allow the VLANs to cross a trunk link to the router. Each subinterface will be the default gateway for a paired subnet. When using subinterfaces on a router, it is necessary to assign the correct VLAN to the subinterface before an IP address can be entered. Because there are three VLANs, you need three subinterfaces.

Step 4-1: Configure the Data VLAN Subinterface

RtrPodx(config-if)# interface fastethernet 0/0.x0
RtrPodx(config-subif)# encapsulation dot1Q x0
RtrPodx(config-subif)# description Data VLAN
RtrPodx(config-subif)# ip address 10.x0.0.1 255.255.255.0

Step 4-2: Configure the Management VLAN Subinterface

RtrPodx(config-subif)# interface fastethernet 0/0.x1
RtrPodx(config-subif)# encapsulation dot1Q x1
RtrPodx(config-subif)# description Management VLAN
RtrPodx(config-subif)# ip address 10.x1.0.1 255.255.255.0

Step 4-3: Configure the Voice VLAN Subinterface

RtrPodx(config-subif)# interface fastethernet 0/0.x5
RtrPodx(config-subif)# encapsulation dot1Q x5
RtrPodx(config-subif)# description Voice VLAN
RtrPodx(config-subif)# ip address 10.x5.0.1 255.255.255.0
RtrPodx(config-subif)# exit

Step 4-4: Activate the Router Interface

RtrPodx(config)# interface fastethernet 0/0
RtrPodx(config-if)# no shutdown

Task 5: Verification

Check the configuration to determine whether it matches what you expect. This will help to avoid future problems.

Step 5-1: Verify Switch VLAN Configuration

Use the show vlan brief command to verify the VLAN configuration. This output is from Pod 11; your output will have different VLAN numbers. Notice that Fa0/1 is a trunk port and as such does not have a VLAN assigned to it, so it will not show in the output.
SwPod11# show vlan
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Gi0/1, Gi0/2
110  Data                             active    Fa0/2, Fa0/3, Fa0/4, Fa0/5
                                                Fa0/6, Fa0/7, Fa0/8, Fa0/9
                                                Fa0/10, Fa0/11, Fa0/12, Fa0/13
                                                Fa0/14, Fa0/15, Fa0/16, Fa0/17
                                                Fa0/18, Fa0/19, Fa0/20, Fa0/21
                                                Fa0/22, Fa0/23, Fa0/24
111  Management                       active
115  Voice                            active    Fa0/2, Fa0/3, Fa0/4, Fa0/5
                                                Fa0/6, Fa0/7, Fa0/8, Fa0/9
                                                Fa0/10, Fa0/11, Fa0/12, Fa0/13
                                                Fa0/14, Fa0/15, Fa0/16, Fa0/17
                                                Fa0/18, Fa0/19, Fa0/20, Fa0/21
                                                Fa0/22, Fa0/23, Fa0/24
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

Step 5-2: Verify Switch Port Assignment

Use the show interfaces switchport command to verify the configuration of trunk and access ports. This output is from Pod 11; your output will have different VLAN numbers. Notice that Fa0/1 is a trunk port, while Fa0/2 is a static access port and has a voice VLAN assigned to it.
SwPod11# show interfaces switchport
Name: Fa0/1
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none



Name: Fa0/2
Switchport: Enabled
Administrative Mode: static access
Operational Mode: down
Administrative Trunking Encapsulation: negotiate
Negotiation of Trunking: Off
Access Mode VLAN: 110 (Data)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: 115 (Voice)

Step 5-3: Verify Router Subinterface IP Assignment

Use the show ip interface brief command to verify that the trunk is assigned correctly. This output is from Pod 11; your output will have different subinterface and IP address numbers.
RtrPod11# show ip interface brief
Interface                  IP-Address      OK? Method  Status                Protocol
FastEthernet0/0            unassigned      YES unset   up                    up
FastEthernet0/0.110        10.110.0.1      YES manual  up                    up
FastEthernet0/0.111        10.111.0.1      YES manual  up                    up
FastEthernet0/0.115        10.115.0.1      YES manual  up                    up

Task 6: DHCP Services

While phones and PCs can be assigned IP addresses statically, DHCP can automatically assign IP address leases. Additionally, DHCP can provide additional information to clients, allowing them to locate necessary resources on the network at the same time they receive an IP address. Using the router as a DHCP server is a quick way to provide DHCP services to clients.
The DHCP option 150 tells Cisco IP Phones the IP address of the TFTP server with the initial configuration file. When using CUCME, the router is the TFTP server by default. This lab assigns the default gateway IP address as the option 150 address, as there is only one way to reach the call agent in this network.

Step 6-1: Configure DHCP Pools on the Router

Always enter the ip dhcp exclude address command before a DHCP pool is created. This avoids IP addresses that should be excluded from being assigned to devices. Enter thenetwork statement as the last command in the pool. Otherwise, if devices are connected, they are assigned an IP address by DHCP right after the network statement is entered, even if the default gateway and option 150 are not configured. This can make troubleshooting difficult, as the PCs and phones will receive IP addresses, but the phones will not register and the PCs will not communicate outside their own subnet without the default router (gateway) address.
Create DHCP pools for both the data and voice networks. While it might seem that option 150 is irrelevant in data VLANs, with software on a PC able to emulate a phone (such as the Cisco IP Communicator software), it makes sense to include it for both DHCP pools.
RtrPodx(config)# ip dhcp excluded-address 10.x0.0.1 10.x0.0.10
RtrPodx(config)# ip dhcp pool Data
RtrPodx(dhcp-config)# default-router 10.x0.0.1
RtrPodx(dhcp-config)# option 150 ip 10.x0.0.1
RtrPodx(dhcp-config)# network 10.x0.0.0 255.255.255.0
RtrPodx(dhcp-config)# exit
RtrPodx(config)# ip dhcp excluded-address 10.x5.0.1 10.x5.0.10
RtrPodx(config)# ip dhcp pool Voice
RtrPodx(dhcp-config)# default-router 10.x5.0.1
RtrPodx(dhcp-config)# option 150 ip 10.x5.0.1
RtrPodx(dhcp-config)# network 10.x5.0.0 255.255.255.0
RtrPodx(dhcp-config)# exit

Task 7: Test and Cleanup

Step 7-1: Test Connectivity

Connect a PC to the switch. Verify that the PC is assigned an IP address from the 10.x0.0.0 /24 subnet. Verify that the PC can telnet to both the router and the switch management IP addresses. If not, troubleshoot the configuration.

Step 7-2: Save the Configurations

Save the configurations into a text file for both the router and switch. They will be needed for future labs.

Step 7-3: (Optional) Explore Power Over Ethernet on the Switch

If you have a switch that is PoE capable and a Cisco IP Phone or two, monitor the console port of the switch and connect the jack on the phone labeled SW to a switch port. SeeFigure 3-2 for an example.
Figure 3-2
Figure 3-2. Cisco IP Phone Connections
If you connect an older Cisco IP Phone (a 7960, for example) that supports only Cisco-proprietary inline power, you might see a message like this on the switch console line:
*Mar  1 05:23:55.900: %ILPOWER-7-DETECT: Interface Fa0/3: Power Device detected:
  Cisco PD
*Mar  1 05:23:55.976: %ILPOWER-5-POWER_GRANTED: Interface Fa0/3: Power granted
If you connect a newer Cisco IP Phone (a 7975, for example) that supports the IEEE 802.1af standard, you might see a message like this on the switch console line:
* Mar  1 05:23:55.858: %ILPOWER-7-DETECT: Interface Fa0/4: Power Device detected:
  IEEE PD
Mar  1 05:23:55.942: %ILPOWER-5-POWER_GRANTED: Interface Fa0/4: Power granted
When verifying PoE usage or troubleshooting phone power problems, you can see the existing PoE usage with the show power inline command. Knowing the remaining PoE capacity is important, as Cisco sells some switch models that do not have enough PoE to fully power all ports, such as the 24-port Catalyst 2960-24LT-L that supports only eight PoE devices at 15.4 watts.
In this output from Pod 11, there are two Cisco IP Phones attached, consuming 18.3 watts, with 351.7 watts of PoE capacity left on this switch. The 7960 phone (6.3 watts) does not have a PoE class, as it does not support 802.1af, while the 7975 phone (12.0 watts) shows as an IEEE PoE Class 3 device.
SwPod11# show power inline
Available:370.0(w)  Used:18.3(w)  Remaining:351.7(w)

Interface Admin  Oper       Power   Device              Class Max
                            (Watts)
--------- ------ ---------- ------- ------------------- ----- ----
Fa0/1     auto   off        0.0     n/a                 n/a   15.4
Fa0/2     auto   off        0.0     n/a                 n/a   15.4
Fa0/3     auto   on         6.3     IP Phone 7960       n/a   15.4
Fa0/4     auto   on         12.0    IP Phone 7975       3     15.4
Fa0/5     auto   off        0.0     n/a                 n/a   15.4
Fa0/6     auto   off        0.0     n/a                 n/a   15.4
At this point, the phones should be attempting to register and will display a message such as “Registering” or “Configuring CM List” (the message will vary depending on the phone model and the version of firmware on the phone). If the phones show “Configuring IP” for more than a few seconds, the DHCP service is not functioning. The messages displayed on the phones are useful information when troubleshooting.

Lab 3-2: Network Time Protocol

Figure 3-3
Figure 3-3. Topology Diagram
Equipment Required
This lab uses the following equipment:
  • Cisco router (and a second Cisco router if Internet access is not allowed from the first router)
  • Switch that supports voice VLANs
Learning Objectives
Upon completion of this lab, you will be able to configure Network Time Protocol (NTP).
Scenario
SOI wants its new data network to use NTP to synchronize time for network devices.
NTP is not only important for synchronizing the time in network device event logs, but also for VoIP to show the correct time on the display of the phones and record the correct timestamp on voicemails, among other uses. The best way to keep everything synchronized is to use an NTP server to coordinate time.
This lab has instructions for two options:
  • Option A assumes access to a production network that can reach an NTP server on the Internet.
  • Option B configures another Cisco router to provide NTP time to simulate an Internet NTP server.
These instructions refer to the Pod Addressing Table in Appendix A to determine the IP addresses and VLAN numbers used for your pod. Wherever an x is shown, substitute the pod number.

Task 1: NTP Services

Step 1-1: Load Prior Configurations

Use the configuration from Lab 3-1. If necessary, load the configuration for both the switch and router.

Step 1-2: (Optional) Configure Local Time Zone

NTP is calculated using UTC (Greenwich Mean Time), but you might want to see the time displayed on the router and phones using your local time zone.
RtrPodx(config)# clock timezone timezone offset-from-GMT
For example, U.S. Central Daylight Time would use clock timezone cdt -6.
RtrPodx(config)# clock summer-time zone recurring
For example, U.S. Central Daylight Time would use clock summer-time cdt recurring.

Step 1-3: Manually Set the Clock

By manually setting the clock close to the correct time, you reduce the amount of time it takes to synchronize with the NTP server. Ideally, you should be within a minute or two of the correct time.
Use the privileged EXEC mode command clock set to manually set time:
RtrPodx# clock set hh:mm:ss day month year
For example, if the current day is Thursday, August 16, 2012 and the time is 9:40 p.m., you would enter clock set 21:40:00 16 August 2012.

Step 1-4 (Option A): Contact an NTP Server on the Internet

(Proceed to Step 1-4 [Option B] if you do not have access to the Internet.)
Configure an interface on the router to reach the Internet. The commands in this step assume that Fast Ethernet 0/1 is cabled to a production network with Internet access and a DHCP server that will assign IP addresses to the router.
RtrPodx(config)# interface fastethernet 0/1
RtrPodx(config-if)# ip address dhcp
RtrPodx(config-if)# no shutdown
RtrPodx(config-if)# exit
RtrPodx(config)# ip route 0.0.0.0 0.0.0.0 gateway-of-Fa0/1-network
A list of NTP stratum two servers can be found at www.ntp.org(http://support.ntp.org/bin/view/Servers/StratumTwoTimeServers). After selecting one close to you, use the ntp server command:
RtrPodx(config)# ntp server ntp_server_IP_address
Skip Step 1-4 (Option B) and go to Step 1-5 to verify NTP operation.

Step 1-4 (Option B): Configure Another Cisco Router to Act as an NTP Server

(Skip this step if you completed Option A.)
The commands in this step assume that Fast Ethernet 0/1 on the voice router is cabled to another Cisco router. (A serial interface could also be used, but the Ethernet interfaces do not require any additional hardware.)
First, configure the other router to connect to the voice router.
Router(config)# hostname NTP_Server
NTP_Server(config)# interface fastethernet 0/0
NTP_Server(config-if)# ip address 192.168.0.1 255.255.255.0
NTP_Server(config-if)# no shutdown
NTP_Server(config-if)# exit
Set the time zones and clock on the NTP_Server router to match the VoIP router (as you did in Steps 1-2 and 1-3).
NTP_Server(config)# clock timezone timezone offset-from-GMT
NTP_Server(config)# clock summer-time zone recurring
NTP_Server# clock set hh:mm:ss day month year
Because you are configuring a “fake” NTP server, it is best to use a higher NTP stratum number to avoid conflicting with real NTP servers. Configure the NTP_Server router to be an NTP time source with the ntp master stratum number command.
NTP_Server(config)# ntp master 4
Configure the VoIP router to connect to the NTP_Server router.
RtrPodx(config)# interface fastethernet 0/1
RtrPodx(config-if)# ip address 192.168.0.2 255.255.255.0
RtrPodx(config-if)# no shutdown
RtrPodx(config-if)# exit
RtrPodx(config)# ntp server 192.168.0.1
RtrPodx(config)# end
Go to Step 1-5 to verify NTP operation.

Step 1-5: Verify That the Time Is Synchronized

Use the following commands to verify that NTP is working:
RtrPodx# show ntp status
RtrPodx# show ntp association
RtrPodx# show ntp association detail
In Examples 3-2a to 3-2g, the Pod 11 router is shown acquiring NTP time from another router. Your results will vary, but the descriptions will help you understand the various outputs you might see as the router uses NTP to synchronize.
The show ntp associations command output start with an “INIT” as the status, while theshow ntp associations detail command output shows the server as “insane, invalid, unsynced” and the filter error is 16 (showing no polling data).

Example 3-2a. Output Showing Pod 11 Router Acquiring NTP Time

RtrPod11# show ntp associations
  address         ref clock       st   when   poll reach  delay  offset   disp
 ~192.168.0.1     .INIT.          16      -     64     0  0.000   0.000 16000.
 * sys.peer, # selected, + candidate, - outlyer, x falseticker, ~ configured
RtrPod11# show ntp associations detail
192.168.0.1 configured, insane, invalid, unsynced, stratum 16
ref ID .INIT., time 00000000.00000000 (18:00:00.000 CDT Thu Dec 31 1899)
our mode client, peer mode unspec, our poll intvl 64, peer poll intvl 1024
root delay 0.00 msec, root disp 0.00, reach 0, sync dist 16.00
delay 0.00 msec, offset 0.0000 msec, dispersion 16000.00
precision 2**24, version 4
org time 00000000.00000000 (18:00:00.000 CDT Thu Dec 31 1899)
rec time 00000000.00000000 (18:00:00.000 CDT Thu Dec 31 1899)
xmt time 00000000.00000000 (18:00:00.000 CDT Thu Dec 31 1899)
filtdelay =     0.00    0.00     0.00    0.00    0.00    0.00    0.00    0.00
filtoffset =    0.00    0.00     0.00    0.00    0.00    0.00    0.00    0.00
filterror =    16.00   16.00    16.00   16.00   16.00   16.00   16.00   16.00
minpoll = 6, maxpoll = 10
After the INIT phase is done (which can take a minute), the router shows the difference between the NTP server time and the time on the router. The router is now establishing the variation in time between the received time and local time. At the point the incrementing “when” counter equals the “poll” number, the NTP server will be queried again.

Example 3-2b. Output Showing Pod 11 Router Acquiring NTP Time

RtrPod11# show ntp associations
  address         ref clock       st   when   poll reach  delay  offset   disp
 ~192.168.0.1     127.127.1.1     10     11     64     1  0.000 -348980 7937.5
 * sys.peer, # selected, + candidate, - outlyer, x falseticker, ~ configured
RtrPod11# show ntp associations
  address         ref clock       st   when   poll reach  delay  offset   disp
 ~192.168.0.1     127.127.1.1     10     44     64     1  0.000 -348980 7937.5
 * sys.peer, # selected, + candidate, - outlyer, x falseticker, ~ configured
In Example 3-2c, the router is 3,489.807 seconds off from the NTP server time. This phase will take several minutes.

Example 3-2c. Output Showing Pod 11 Router Acquiring NTP Time

RtrPod11# show ntp associations detail
192.168.0.1 configured, insane, invalid, stratum 10
ref ID 127.127.1.1   , time D22D35B2.32265329 (00:57:06.195 CDT Wed Sep 28 2011)
our mode client, peer mode server, our poll intvl 64, peer poll intvl 64
root delay 0.00 msec, root disp 0.30, reach 1, sync dist 7.94
delay 0.00 msec, offset -3489807.6733 msec, dispersion 7937.50
precision 2**24, version 4
org time D22D35B8.CB5A7071 (00:57:12.794 CDT Wed Sep 28 2011)
rec time D22D435A.9A57C7DE (01:55:22.602 CDT Wed Sep 28 2011)
xmt time D22D435A.99DE9D3F (01:55:22.601 CDT Wed Sep 28 2011)
filtdelay =     0.00    0.00    0.00    0.00    0.00    0.00    0.00    0.00
filtoffset = -3489.8    0.00    0.00    0.00    0.00    0.00    0.00    0.00
filterror =     0.00   16.00   16.00   16.00   16.00   16.00   16.00   16.00
minpoll = 6, maxpoll = 10
The next phase is to accept the time from the NTP server and establish the accuracy of the local clock. Notice that the router is just over 2 milliseconds off from the NTP server. The “filteroffset” and “filtererror” are now 0 for the first poll.

Example 3-2d. Output Showing Pod 11 Router Acquiring NTP Time

RtrPod11# show ntp associations detail
192.168.0.1 configured, insane, invalid, stratum 10
ref ID 127.127.1.1   , time D22D36A0.3225413B (01:01:04.195 CDT Wed Sep 28 2011)
our mode client, peer mode server, our poll intvl 64, peer poll intvl 64
root delay 0.00 msec, root disp 0.21, reach 1, sync dist 7.94
delay 0.00 msec, offset 2.2946 msec, dispersion 7937.50
precision 2**24, version 4
org time D22D36A0.CC349A2D (01:01:04.797 CDT Wed Sep 28 2011)
rec time D22D36A0.CBD66632 (01:01:04.796 CDT Wed Sep 28 2011)
xmt time D22D36A0.CB603CB8 (01:01:04.794 CDT Wed Sep 28 2011)
filtdelay =     0.00    0.00    0.00    0.00    0.00    0.00    0.00    0.00
filtoffset =    0.00    0.00    0.00    0.00    0.00    0.00    0.00    0.00
filterror =     0.00   16.00   16.00   16.00   16.00   16.00   16.00   16.00
minpoll = 6, maxpoll = 10
Every 64 seconds, the router polls the NTP server again. You can see the polls show up, as the “filtererror” is gradually set to 0 for each new poll.

Example 3-2e. Output Showing Pod 11 Router Acquiring NTP Time

RtrPod11# show ntp associations
192.168.0.1 configured, insane, invalid, stratum 10
ref ID 127.127.1.1   , time D22D36D2.32254796 (01:01:54.195 CDT Wed Sep 28 2011)
our mode client, peer mode server, our poll intvl 64, peer poll intvl 64
root delay 0.00 msec, root disp 0.44, reach 3, sync dist 3.94
delay 0.00 msec, offset 3.1598 msec, dispersion 3937.73
precision 2**24, version 4
org time D22D36DF.CC672189 (01:02:07.798 CDT Wed Sep 28 2011)
rec time D22D36DF.CBD02AD0 (01:02:07.796 CDT Wed Sep 28 2011)
xmt time D22D36DF.CB5A1A5B (01:02:07.794 CDT Wed Sep 28 2011)
filtdelay =     0.00    0.00    0.00    0.00    0.00    0.00    0.00    0.00
filtoffset =    0.00    0.00    0.00    0.00    0.00    0.00    0.00    0.00
filterror =     0.00    0.00   16.00   16.00   16.00   16.00   16.00   16.00
minpoll = 6, maxpoll = 10
After enough polls have been completed, the time on the router is NTP synchronized. Your router now considers the NTP server “our master, sane, and valid.”

Example 3-2f. Output Showing Pod 11 Router Acquiring NTP Time

RtrPod11# show ntp associations detail
192.168.0.1 configured, our_master, sane, valid, stratum 10                             
ref ID 127.127.1.1   , time D22D3756.32286702 (01:04:06.195 CDT Wed Sep 28 2011)
our mode client, peer mode server, our poll intvl 64, peer poll intvl 64
root delay 0.00 msec, root disp 0.39, reach 17, sync dist 0.94
delay 0.00 msec, offset 3.1598 msec, dispersion 939.24
precision 2**24, version 4
org time D22D3760.CCE2CF70 (01:04:16.800 CDT Wed Sep 28 2011)
rec time D22D3760.CBD604CE (01:04:16.796 CDT Wed Sep 28 2011)
xmt time D22D3760.CB5F51F8 (01:04:16.794 CDT Wed Sep 28 2011)
filtdelay =     0.00    0.00    0.00    0.00    0.00    0.00    0.00    0.00
filtoffset =    0.00    0.00    0.00    0.00    0.00    0.00    0.00    0.00
filterror =     0.00    0.00    0.00    0.00   16.00   16.00   16.00   16.00
minpoll = 6, maxpoll = 10
The asterisk (*) in front of the NTP server IP address shows that the server is synchronized. The show ntp status command also shows that the server is synchronized.

Example 3-2g. Output Showing Pod 11 Router Acquiring NTP Time

RtrPod11# show ntp associations
  address         ref clock       st   when   poll reach  delay  offset   disp
*~192.168.0.1     127.127.1.1     10     21     64   377  0.000  15.598  4.689
 * sys.peer, # selected, + candidate, - outlyer, x falseticker, ~ configured
RtrPod11# show ntp status
Clock is synchronized, stratum 11, reference is 192.168.0.1
nominal freq is 250.0000 Hz, actual freq is 249.9998 Hz, precision is 2**24
reference time is D22D3760.CBD604CE (01:04:16.796 CDT Wed Sep 28 2011)
clock offset is 0.0031 msec, root delay is 0.00 msec
root dispersion is 0.94 msec, peer dispersion is 0.44 msec
loopfilter state is 'CTRL' (Normal Controlled Loop), drift is 0.000000722 s/s
system poll interval is 64, last update was 99 sec ago.

Step 1-6: (Optional) Configure the Switch to Get NTP from the Router

For the sake of making sure that all networking devices are synchronized using NTP, the switch should use the router as an NTP source.
SwPodx(config)# clock timezone timezone offset-from-GMT
SwPodx(config)# clock summer-time zone recurring
SwPodx(config)# ntp server 10.x1.0.1

Step 1-7: Save the Configurations

Save the configurations into a text file for both the router and switch. They will be needed for future labs.

Lab 3-3: Phone Boot/Registration Process

Equipment Required
No equipment is required for this lab.
Learning Objectives
Upon completion of this lab, you will better understand the Cisco IP Phone boot and registration process.

Task 1: Questions

The most important part of solving problems with VoIP solutions is knowing how a properly functioning system should work and comparing it to an existing problem. Cisco IP Phones have multiple steps to complete when connected to the network, and understanding the process from booting to registration will speed resolution of problems.
Question 3.1
List at least three ways that a Cisco IP Phone can receive power.
1.___________________________________________________________________________
2.___________________________________________________________________________
3.___________________________________________________________________________
Question 3.2
What two protocols can Cisco IP Phones use to register to the Call Agent (depending on the phone firmware loaded)?
1.___________________________________________________________________________
2.___________________________________________________________________________
Question 3.3
Number the following steps in the order they occur during the phone boot process:
___ The phone downloads the configuration file from the TFTP server.
___ The phone gets IP address information from DHCP, including option 150.
___ The phone registers with one or more Call Agents.
___ The phone receives power, which might involve receiving PoE from the switch.
___ The phone learns the VLAN information from CDP.

info copy by:CISCOPRESS

Sem comentários:

Enviar um comentário

Ajudem nos a melhorar o nosso blog: