25.1.16

16 commands to check hardware information on Linux

Hardware information

Like for every thing, there are plenty of commands to check information about the hardware of your linux system. Some commands report only specific hardware components like cpu or memory while the rest cover multiple hardware units.
This post takes a quick look at some of the most commonly used commands to check information and configuration details about various hardware peripherals and devices. The list includes lscpu, hwinfo, lshw, dmidecode, lspci etc.

1. lscpu

The lscpu command reports information about the cpu and processing units. It does not have any further options or functionality.
$ lscpu
Architecture:          x86_64
CPU op-mode(s):        32-bit, 64-bit
Byte Order:            Little Endian
CPU(s):                4
On-line CPU(s) list:   0-3
Thread(s) per core:    1
Core(s) per socket:    4
Socket(s):             1
NUMA node(s):          1
Vendor ID:             GenuineIntel
CPU family:            6
Model:                 23
Stepping:              10
CPU MHz:               1998.000
BogoMIPS:              5302.48
Virtualization:        VT-x
L1d cache:             32K
L1i cache:             32K
L2 cache:              2048K
NUMA node0 CPU(s):     0-3

2. lshw - List Hardware

A general purpose utility, that reports detailed and brief information about multiple different hardware units such as cpu, memory, disk, usb controllers, network adapters etc. Lshw extracts the information from different /proc files.
$ sudo lshw -short

H/W path        Device      Class       Description
===================================================
                            system      ()
/0                          bus         DG35EC
/0/0                        processor   Intel(R) Core(TM)2 Quad CPU    Q8400  @ 2.66GHz
/0/0/1                      memory      2MiB L2 cache
/0/0/3                      memory      32KiB L1 cache
/0/2                        memory      32KiB L1 cache
/0/4                        memory      64KiB BIOS
/0/14                       memory      8GiB System Memory
/0/14/0                     memory      2GiB DIMM DDR2 Synchronous 667 MHz (1.5 ns)
/0/14/1                     memory      2GiB DIMM DDR2 Synchronous 667 MHz (1.5 ns)
/0/14/2                     memory      2GiB DIMM DDR2 Synchronous 667 MHz (1.5 ns)
/0/14/3                     memory      2GiB DIMM DDR2 Synchronous 667 MHz (1.5 ns)
/0/100                      bridge      82G35 Express DRAM Controller
/0/100/2                    display     82G35 Express Integrated Graphics Controller
/0/100/2.1                  display     82G35 Express Integrated Graphics Controller
/0/100/19       eth0        network     82566DC Gigabit Network Connection
/0/100/1a                   bus         82801H (ICH8 Family) USB UHCI Controller #4
/0/100/1a.1                 bus         82801H (ICH8 Family) USB UHCI Controller #5
/0/100/1a.7                 bus         82801H (ICH8 Family) USB2 EHCI Controller #2
/0/100/1b                   multimedia  82801H (ICH8 Family) HD Audio Controller
/0/100/1c                   bridge      82801H (ICH8 Family) PCI Express Port 1
/0/100/1c.1                 bridge      82801H (ICH8 Family) PCI Express Port 2
/0/100/1c.2                 bridge      82801H (ICH8 Family) PCI Express Port 3
/0/100/1c.2/0               storage     JMB368 IDE controller
/0/100/1d                   bus         82801H (ICH8 Family) USB UHCI Controller #1
/0/100/1d.1                 bus         82801H (ICH8 Family) USB UHCI Controller #2
/0/100/1d.2                 bus         82801H (ICH8 Family) USB UHCI Controller #3
/0/100/1d.7                 bus         82801H (ICH8 Family) USB2 EHCI Controller #1
/0/100/1e                   bridge      82801 PCI Bridge
/0/100/1e/5                 bus         FW322/323 [TrueFire] 1394a Controller
/0/100/1f                   bridge      82801HB/HR (ICH8/R) LPC Interface Controller
/0/100/1f.2                 storage     82801H (ICH8 Family) 4 port SATA Controller [IDE mode]
/0/100/1f.3                 bus         82801H (ICH8 Family) SMBus Controller
/0/100/1f.5                 storage     82801HR/HO/HH (ICH8R/DO/DH) 2 port SATA Controller [IDE m
/0/1            scsi3       storage     
/0/1/0.0.0      /dev/sda    disk        500GB ST3500418AS
/0/1/0.0.0/1    /dev/sda1   volume      70GiB Windows NTFS volume
/0/1/0.0.0/2    /dev/sda2   volume      395GiB Extended partition
/0/1/0.0.0/2/5  /dev/sda5   volume      97GiB HPFS/NTFS partition
/0/1/0.0.0/2/6  /dev/sda6   volume      97GiB Linux filesystem partition
/0/1/0.0.0/2/7  /dev/sda7   volume      1952MiB Linux swap / Solaris partition
/0/1/0.0.0/2/8  /dev/sda8   volume      198GiB Linux filesystem partition
/0/3            scsi4       storage     
/0/3/0.0.0      /dev/cdrom  disk        DVD RW DRU-190A
Check out the following post to learn more about lshw
Get hardware information on Linux with lshw command

3. hwinfo - Hardware Information

Hwinfo is another general purpose hardware probing utility that can report detailed and brief information about multiple different hardware components, and more than what lshw can report.
$ hwinfo --short
cpu:                                                            
                       Intel(R) Core(TM)2 Quad CPU    Q8400  @ 2.66GHz, 2000 MHz
                       Intel(R) Core(TM)2 Quad CPU    Q8400  @ 2.66GHz, 2000 MHz
                       Intel(R) Core(TM)2 Quad CPU    Q8400  @ 2.66GHz, 2666 MHz
                       Intel(R) Core(TM)2 Quad CPU    Q8400  @ 2.66GHz, 2666 MHz
keyboard:
  /dev/input/event2    AT Translated Set 2 keyboard
mouse:
  /dev/input/mice      Microsoft Basic Optical Mouse v2.0
graphics card:
                       Intel 965G-1
                       Intel 82G35 Express Integrated Graphics Controller
sound:
                       Intel 82801H (ICH8 Family) HD Audio Controller
storage:
                       Intel 82801H (ICH8 Family) 4 port SATA IDE Controller
                       Intel 82801H (ICH8 Family) 2 port SATA IDE Controller
                       JMicron JMB368 IDE controller
network:
  eth0                 Intel 82566DC Gigabit Network Connection
network interface:
  eth0                 Ethernet network interface
  lo                   Loopback network interface
disk:
  /dev/sda             ST3500418AS
partition:
  /dev/sda1            Partition
  /dev/sda2            Partition
  /dev/sda5            Partition
  /dev/sda6            Partition
  /dev/sda7            Partition
  /dev/sda8            Partition
cdrom:
  /dev/sr0             SONY DVD RW DRU-190A
usb controller:
                       Intel 82801H (ICH8 Family) USB UHCI Controller #4
                       Intel 82801H (ICH8 Family) USB UHCI Controller #5
                       Intel 82801H (ICH8 Family) USB2 EHCI Controller #2
                       Intel 82801H (ICH8 Family) USB UHCI Controller #1
                       Intel 82801H (ICH8 Family) USB UHCI Controller #2
                       Intel 82801H (ICH8 Family) USB UHCI Controller #3
                       Intel 82801H (ICH8 Family) USB2 EHCI Controller #1
bios:
                       BIOS

... TRUNCATED ...
Check out our previous post on hwinfo
Check hardware information on Linux with hwinfo command

4. lspci - List PCI

The lspci command lists out all the pci buses and details about the devices connected to them.
The vga adapter, graphics card, network adapter, usb ports, sata controllers, etc all fall under this category.
$ lspci
00:00.0 Host bridge: Intel Corporation 82G35 Express DRAM Controller (rev 03)
00:02.0 VGA compatible controller: Intel Corporation 82G35 Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation 82G35 Express Integrated Graphics Controller (rev 03)
00:19.0 Ethernet controller: Intel Corporation 82566DC Gigabit Network Connection (rev 02)
00:1a.0 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 (rev 02)
00:1a.1 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 02)
00:1a.7 USB controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 02)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 (rev 02)
00:1c.2 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 3 (rev 02)
00:1d.0 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 02)
00:1d.7 USB controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev f2)
00:1f.0 ISA bridge: Intel Corporation 82801HB/HR (ICH8/R) LPC Interface Controller (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801H (ICH8 Family) 4 port SATA Controller [IDE mode] (rev 02)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 02)
00:1f.5 IDE interface: Intel Corporation 82801HR/HO/HH (ICH8R/DO/DH) 2 port SATA Controller [IDE mode] (rev 02)
03:00.0 IDE interface: JMicron Technology Corp. JMB368 IDE controller
04:05.0 FireWire (IEEE 1394): LSI Corporation FW322/323 [TrueFire] 1394a Controller (rev 70)
Filter out specific device information with grep.
$ lspci -v | grep "VGA" -A 12

5. lsscsi - List scsi devices

Lists out the scsi/sata devices like hard drives and optical drives.
$ lsscsi
[3:0:0:0]    disk    ATA      ST3500418AS      CC38  /dev/sda 
[4:0:0:0]    cd/dvd  SONY     DVD RW DRU-190A  1.63  /dev/sr0

6. lsusb - List usb buses and device details

This command shows the USB controllers and details about devices connected to them. By default brief information is printed. Use the verbose option "-v" to print detailed information about each usb port
$ lsusb
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 002: ID 045e:00cb Microsoft Corp. Basic Optical Mouse v2.0
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
On the above system, 1 usb port is being used by the mouse.

7. Inxi

Inxi is a 10K line mega bash script that fetches hardware details from multiple different sources and commands on the system, and generates a beautiful looking report that non technical users can read easily.
$ inxi -Fx
inxi linux hardware information tool

8. lsblk - List block devices

List out information all block devices, which are the hard drive partitions and other storage devices like optical drives and flash drives
$ lsblk
NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda      8:0    0 465.8G  0 disk 
├─sda1   8:1    0    70G  0 part 
├─sda2   8:2    0     1K  0 part 
├─sda5   8:5    0  97.7G  0 part /media/4668484A68483B47
├─sda6   8:6    0  97.7G  0 part /
├─sda7   8:7    0   1.9G  0 part [SWAP]
└─sda8   8:8    0 198.5G  0 part /media/13f35f59-f023-4d98-b06f-9dfaebefd6c1
sr0     11:0    1  1024M  0 rom

9. df - disk space of file systems

Reports various partitions, their mount points and the used and available space on each.
$ df -H
Filesystem      Size  Used Avail Use% Mounted on
/dev/sda6       104G   26G   73G  26% /
none            4.1k     0  4.1k   0% /sys/fs/cgroup
udev            4.2G  4.1k  4.2G   1% /dev
tmpfs           837M  1.6M  835M   1% /run
none            5.3M     0  5.3M   0% /run/lock
none            4.2G   13M  4.2G   1% /run/shm
none            105M   21k  105M   1% /run/user
/dev/sda8       210G  149G   51G  75% /media/13f35f59-f023-4d98-b06f-9dfaebefd6c1
/dev/sda5       105G   31G   75G  30% /media/4668484A68483B47

10. Pydf - Python df

An improved df version written in python, that displays colored output that looks better than df
$ pydf
Filesystem Size Used Avail Use%          Mounted on                                 
/dev/sda6   96G  23G   68G 24.4 [#.....] /                                          
/dev/sda8  195G 138G   47G 70.6 [####..] /media/13f35f59-f023-4d98-b06f-9dfaebefd6c1
/dev/sda5   98G  28G   69G 29.2 [##....] /media/4668484A68483B47

11. fdisk

Fdisk is a utility to modify partitions on hard drives, and can be used to list out the partition information as well.
$ sudo fdisk -l

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x30093008

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *          63   146801969    73400953+   7  HPFS/NTFS/exFAT
/dev/sda2       146802031   976771071   414984520+   f  W95 Ext'd (LBA)
/dev/sda5       146802033   351614654   102406311    7  HPFS/NTFS/exFAT
/dev/sda6       351614718   556427339   102406311   83  Linux
/dev/sda7       556429312   560427007     1998848   82  Linux swap / Solaris
/dev/sda8       560429056   976771071   208171008   83  Linux

12. mount

The mount is used to mount/unmount and view mounted file systems.
$ mount | column -t
/dev/sda6    on  /                                            type  ext4             (rw,errors=remount-ro)
proc         on  /proc                                        type  proc             (rw,noexec,nosuid,nodev)
sysfs        on  /sys                                         type  sysfs            (rw,noexec,nosuid,nodev)
none         on  /sys/fs/cgroup                               type  tmpfs            (rw)
none         on  /sys/fs/fuse/connections                     type  fusectl          (rw)
none         on  /sys/kernel/debug                            type  debugfs          (rw)
none         on  /sys/kernel/security                         type  securityfs       (rw)
udev         on  /dev                                         type  devtmpfs         (rw,mode=0755)
devpts       on  /dev/pts                                     type  devpts           (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs        on  /run                                         type  tmpfs            (rw,noexec,nosuid,size=10%,mode=0755)
none         on  /run/lock                                    type  tmpfs            (rw,noexec,nosuid,nodev,size=5242880)
none         on  /run/shm                                     type  tmpfs            (rw,nosuid,nodev)
none         on  /run/user                                    type  tmpfs            (rw,noexec,nosuid,nodev,size=104857600,mode=0755)
none         on  /sys/fs/pstore                               type  pstore           (rw)
/dev/sda8    on  /media/13f35f59-f023-4d98-b06f-9dfaebefd6c1  type  ext4             (rw,nosuid,nodev,errors=remount-ro)
/dev/sda5    on  /media/4668484A68483B47                      type  fuseblk          (rw,nosuid,nodev,allow_other,blksize=4096)
binfmt_misc  on  /proc/sys/fs/binfmt_misc                     type  binfmt_misc      (rw,noexec,nosuid,nodev)
systemd      on  /sys/fs/cgroup/systemd                       type  cgroup           (rw,noexec,nosuid,nodev,none,name=systemd)
gvfsd-fuse   on  /run/user/1000/gvfs                          type  fuse.gvfsd-fuse  (rw,nosuid,nodev,user=enlightened)
Again, use grep to filter out only those file systems that you want to see
$ mount | column -t | grep ext

13. free - Check RAM

Check the amount of used, free and total amount of RAM on system with the free command.
$ free -m
             total       used       free     shared    buffers     cached
Mem:          7975       5865       2110          0         24        622
-/+ buffers/cache:       5218       2757
Swap:         1951        921       1030

14. dmidecode

The dmidecode command is different from all other commands. It extracts hardware information by reading data from the SMBOIS data structures (also called DMI tables).
# display information about the processor/cpu
$ sudo dmidecode -t processor

# memory/ram information
$ sudo dmidecode -t memory

# bios details
$ sudo dmidecode -t bios
Check out the man page for more details.

15. /proc files

Many of the virtual files in the /proc directory contain information about hardware and configurations. Here are some of them
CPU/Memory information
# cpu information
$ cat /proc/cpuinfo

# memory information
$ cat /proc/meminfo
Linux/kernel information
$ cat /proc/version
Linux version 3.11.0-12-generic (buildd@allspice) (gcc version 4.8.1 (Ubuntu/Linaro 4.8.1-10ubuntu7) ) #19-Ubuntu SMP Wed Oct 9 16:20:46 UTC 2013
SCSI/Sata devices
$ cat /proc/scsi/scsi 
Attached devices:
Host: scsi3 Channel: 00 Id: 00 Lun: 00
  Vendor: ATA      Model: ST3500418AS      Rev: CC38
  Type:   Direct-Access                    ANSI  SCSI revision: 05
Host: scsi4 Channel: 00 Id: 00 Lun: 00
  Vendor: SONY     Model: DVD RW DRU-190A  Rev: 1.63
  Type:   CD-ROM                           ANSI  SCSI revision: 05
Partitions
$ cat /proc/partitions 
major minor  #blocks  name

   8        0  488386584 sda
   8        1   73400953 sda1
   8        2          1 sda2
   8        5  102406311 sda5
   8        6  102406311 sda6
   8        7    1998848 sda7
   8        8  208171008 sda8
  11        0    1048575 sr0

16. hdparm

The hdparm command gets information about sata devices like hard disks.
$ sudo hdparm -i /dev/sda

/dev/sda:

 Model=ST3500418AS, FwRev=CC38, SerialNo=9VMJXV1N
 Config={ HardSect NotMFM HdSw>15uSec Fixed DTR>10Mbs RotSpdTol>.5% }
 RawCHS=16383/16/63, TrkSize=0, SectSize=0, ECCbytes=4
 BuffType=unknown, BuffSize=16384kB, MaxMultSect=16, MultSect=16
 CurCHS=16383/16/63, CurSects=16514064, LBA=yes, LBAsects=976773168
 IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
 PIO modes:  pio0 pio1 pio2 pio3 pio4 
 DMA modes:  mdma0 mdma1 mdma2 
 UDMA modes: udma0 udma1 udma2 udma3 udma4 udma5 *udma6 
 AdvancedPM=no WriteCache=enabled
 Drive conforms to: unknown:  ATA/ATAPI-4,5,6,7

 * signifies the current active mode

Summary

Each of the command has a slightly different method of extracting information, and you may need to try more than one of them, while looking for specific hardware details. However they are available across most linux distros, and can be easily installed from the default repositories.
On the desktop there are gui tools, for those who do not want to memorise and type commands. Hardinfo, I-nex are some of the popular ones that provide detailed information about multiple different hardware components.
 

Como extrair as chaves (licensa) do windows 8 da BIOS/UEFI

3 Ways to extract the Windows 8 Product key from the BIOS/UEFI

Sometimes you need your Windows 8 Product Key, In Versions prior to Windows 8 this was fairly easy you could just look at the Product key sticker on your Computer. But since Windows 8 Microsoft made a change. Most likely you won’t have a product sticker anymore. Instead they save the Product key in your BIOS/UEFI. This is a pretty nice feature, since now when you reinstall windows 8 it will automatically retrieve your Product Key from the BIOS/UEFI. But Retrieving the Product key on your own got a bit more complicated. But luckily we can still extract it. If you are not able to boot up windows, look at the last part of Method 1 this will describe a method which does not require a installed version of windows.
Method 1:
Download RW-EVERYTHING. The download can be found here: http://rweverything.com/download/ the easiest way is to choose the RWPortable version. Make sure you choose the right one for your version of Windows. When downloaded extract the ZIP file. And execute “RW.exe”
Click on the ACPI Table button at the top. After that click on the MSDM tab. Your BIOS’s product key is at the bottom.
rweverything product key

If you are for some reason unable to boot up windows, we can try another way. This involves HirensBootCD which can be downloaded here: http://www.hirensbootcd.org/download/ this will download an .ISO which you will need to burn onto a CD or alternatively make a bootable USB. I am going to assume you already know how to Burn an image to a CD.  If not you can have a look here: http://windows.microsoft.com/en-gb/windows7/burn-a-cd-or-dvd-from-an-iso-file
Now boot off the CD/USB and select Mini Windows XP, this will boot a minimal version of Windows XP right of your CD. After this you can insert a USB with the RWportable 32 bit version on it. And Extract the product key the same way as explained above. If you don’t know how to boot from a CD/USB have a look here: http://lifehacker.com/5991848/how-to-boot-from-a-cd-or-usb-drive-on-any-pc
Method 2:
The second option is probably a bit easier. The guys at Mydigitallife.info made a nice little tool that can extract the product code. You can find the tool here:
NOTE: Unlinked due to Adware, proceed at your own risk
http://forums.mydigitallife.info/threads/30363-Windows-8-Product-Key-Viewer?p=510104&viewfull=1#post510104
When downloaded extract the .rar file. And open it up to extract the product code stored in the BIOS/UEFI select the MSDM KEY option.
windows 8 product code viewer
Method 3:
Christian Korneck made a script that can be run from within windows, this will also extract the Product code from within the Firmware. You can get the necessary files on Github:
Download the get_win8key.exe and save it on an easy to remember location like C:\Win8key now open up a PowerShell Shell. In windows 8 you can easily find this by going to start and just type PowerShell.
Now type:
& "C:\win8key\get_win8key.exe"
(Including the & sign)
powershell product code windows 8
I hope this helped.

 

Mikrotik Scrips

Aprenda a criar scrips no seu router Mikrotik atravez do link abaixo

Fax2Email

Crie seu fax2email, para que receba fax no seu email

CCNA VOICE Lab Manual: Establishing Network Connectivity and Understanding IP Phone Registration

In both Cisco Unified Communications Manager Express (CUCME) and Cisco Unified Communications Manager (CUCM) environments, phones need to connect to the network to receive services such as IP addresses from DHCP, VLAN assignments for voice traffic, IP information on where to register, and Network Time Protocol (NTP) packets. This chapter focuses on establishing those services.
In this chapter, you will set up a voice network for the fictitious company Shiny Objects Incorporated (SOI). Before phones are connected, you must establish network connectivity and configure needed services.

Lab 3-1: Network Connectivity

Equipment Required
This lab uses the following equipment:
  • Cisco router
  • Switch that supports voice VLANs
  • PC for testing
  • Cisco IP Phone (optional, but useful if switch supports Power over Ethernet [PoE])
Learning Objectives
Upon completion of this lab, you will be able to
  • Perform basic router and switch configuration
  • Configure VLANs to support data, voice, and network management traffic
  • Configure VLAN trunking between a router and a switch using subinterfaces
  • Configure router-based DHCP pools for voice and data devices
Scenario
SOI would like to establish its new data network with the expectation of using VoIP in the near future.
These instructions refer to the Pod Addressing Table in Appendix A to determine the IP addresses and VLAN numbers used for your pod. Wherever an x is shown, substitute the pod number.

Task 1: Clear and Cable Devices

Because the CCNA is a prerequisite for the CCNA-Voice certification exam, this book assumes that you are familiar with clearing prior configurations.

Step 1-1: Clear Prior Configurations

Clear any prior configuration on the router and switch, and delete the vlan.dat file before reloading both devices.

Step 1-2: Cable Router and Switch

Cable router interface Fast Ethernet 0/0 to switch port Fast Ethernet 0/1, as shown inFigure 3-1. The PC will be connected later.
Figure 3-1
Figure 3-1. Topology Diagram

Task 2: Configure Basic Setup

This task establishes the basic configuration commands on both the router and switch.

Step 2-1: Configure Basic Setup on the Router

Router(config)# hostname RtrPodx
For example, Pod 8 would use hostname RtrPod8.
RtrPodx(config)# no ip domain-lookup
RtrPodx(config)# enable secret class
RtrPodx(config)# line con 0
RtrPodx(config-line)# logging synchronous
RtrPodx(config-line)# exec-timeout 120 0
RtrPodx(config-line)# password cisco
RtrPodx(config-line)# login
RtrPodx(config-line)# line vty 0 15
RtrPodx(config-line)# password cisco
RtrPodx(config-line)# login
RtrPodx(config-line)# exit

Step 2-2: Configure Basic Setup on the Switch

Switch(config)# hostname SwPodx
For example, Pod 3 would use hostname SwPod3
SwPodx(config)# no ip domain-lookup
SwPodx(config)# enable secret class
SwPodx(config)# line con 0
SwPodx(config-line)# logging synchronous
SwPodx(config-line)# exec-timeout 120 0
SwPodx(config-line)# password cisco
SwPodx(config-line)# login
SwPodx(config-line)# line vty 0 15
SwPodx(config-line)# password cisco
SwPodx(config-line)# login
SwPodx(config-line)# exit

Task 3: Configure the Switch

For the purposes of security and ease of implementing quality of service (QoS), use VLANs to keep voice traffic separate from other traffic.

Step 3-1: Create the VLANs

Create and name VLANs for data, voice, and network management.
SwPodx(config)# vlan x0
SwPodx(config-vlan)# name Data
SwPodx(config-vlan)# vlan x1
SwPodx(config-vlan)# name Management
SwPodx(config-vlan)# vlan x5
SwPodx(config-vlan)# name Voice
SwPodx(config-vlan)# exit

Step 3-2: Configure the Trunk Port

Configure the trunk port that connects the switch to the router. Layer 3 switches (such as the Cisco Catalyst 3560) require that the trunking protocol be specified with the switchport trunk encapsulation command before the interface can be set as a trunk. If you are using a Layer 2 switch (such as a Cisco Catalyst 2950 or 2960), the command is not needed and will be rejected.
SwPodx(config)# interface fastethernet 0/1
SwPodx(config-if)# switchport trunk encapsulation dot1q
SwPodx(config-if)# switchport mode trunk
SwPodx(config-if)# exit

Step 3-3: Configure the Access Ports

Almost all Cisco IP Phones are designed with a three-port switch built inside (one physical port connected to the production switch, one physical port for a PC to connect to the phone, and one internal port for the phone itself). This built-in switch saves money in wiring costs, as existing phone cabling might not meet networking standards. This enables an existing computer to be plugged into the phone, and the phone connects to the switch in the wiring closet.
Prior to the introduction of voice VLANs, a trunk connected an IP Phone to the switch to keep the voice and data traffic separate. Current best practice configures the ports connected to phones and PCs to use access mode but adds a secondary voice VLAN. The switch ports use the access VLAN to send data traffic as untagged frames. However, if the switch detects a Cisco IP Phone using Cisco Discovery Protocol (CDP), it will inform the phone of the VLAN used for voice traffic, which will be tagged using 802.1q. This creates a pseudotrunk that allows only the data and voice VLANs on the link.
Use the interface range command to assign settings. This is the fastest way to assign settings to more than one switch port at a time.
SwPodx(config)# interface range fastethernet 0/2 – 24
SwPodx(config-if-range)# switchport mode access
SwPodx(config-if-range)# switchport access vlan x0
SwPodx(config-if-range)# switchport voice vlan x5
SwPodx(config-if-range)# exit

Example 3-1. Verify That spanning-tree portfast Is Created by the Voice VLAN Assignment

SwPod11# show run



interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/2
 switchport access vlan 110
 switchport mode access
 switchport voice vlan 115
 spanning-tree portfast


Step 3-4: Configure the Switch Management Interface

Set up an interface to manage the switch remotely.
SwPodx(config)# interface vlan x1
SwPodx(config-if)# ip address 10.x1.0.2 255.255.255.0
SwPodx(config-if)# exit
SwPodx(config)# ip default-gateway 10.x1.0.1

Task 4: Configure the Router Subinterfaces

Subinterfaces allow the VLANs to cross a trunk link to the router. Each subinterface will be the default gateway for a paired subnet. When using subinterfaces on a router, it is necessary to assign the correct VLAN to the subinterface before an IP address can be entered. Because there are three VLANs, you need three subinterfaces.

Step 4-1: Configure the Data VLAN Subinterface

RtrPodx(config-if)# interface fastethernet 0/0.x0
RtrPodx(config-subif)# encapsulation dot1Q x0
RtrPodx(config-subif)# description Data VLAN
RtrPodx(config-subif)# ip address 10.x0.0.1 255.255.255.0

Step 4-2: Configure the Management VLAN Subinterface

RtrPodx(config-subif)# interface fastethernet 0/0.x1
RtrPodx(config-subif)# encapsulation dot1Q x1
RtrPodx(config-subif)# description Management VLAN
RtrPodx(config-subif)# ip address 10.x1.0.1 255.255.255.0

Step 4-3: Configure the Voice VLAN Subinterface

RtrPodx(config-subif)# interface fastethernet 0/0.x5
RtrPodx(config-subif)# encapsulation dot1Q x5
RtrPodx(config-subif)# description Voice VLAN
RtrPodx(config-subif)# ip address 10.x5.0.1 255.255.255.0
RtrPodx(config-subif)# exit

Step 4-4: Activate the Router Interface

RtrPodx(config)# interface fastethernet 0/0
RtrPodx(config-if)# no shutdown

Task 5: Verification

Check the configuration to determine whether it matches what you expect. This will help to avoid future problems.

Step 5-1: Verify Switch VLAN Configuration

Use the show vlan brief command to verify the VLAN configuration. This output is from Pod 11; your output will have different VLAN numbers. Notice that Fa0/1 is a trunk port and as such does not have a VLAN assigned to it, so it will not show in the output.
SwPod11# show vlan
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Gi0/1, Gi0/2
110  Data                             active    Fa0/2, Fa0/3, Fa0/4, Fa0/5
                                                Fa0/6, Fa0/7, Fa0/8, Fa0/9
                                                Fa0/10, Fa0/11, Fa0/12, Fa0/13
                                                Fa0/14, Fa0/15, Fa0/16, Fa0/17
                                                Fa0/18, Fa0/19, Fa0/20, Fa0/21
                                                Fa0/22, Fa0/23, Fa0/24
111  Management                       active
115  Voice                            active    Fa0/2, Fa0/3, Fa0/4, Fa0/5
                                                Fa0/6, Fa0/7, Fa0/8, Fa0/9
                                                Fa0/10, Fa0/11, Fa0/12, Fa0/13
                                                Fa0/14, Fa0/15, Fa0/16, Fa0/17
                                                Fa0/18, Fa0/19, Fa0/20, Fa0/21
                                                Fa0/22, Fa0/23, Fa0/24
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

Step 5-2: Verify Switch Port Assignment

Use the show interfaces switchport command to verify the configuration of trunk and access ports. This output is from Pod 11; your output will have different VLAN numbers. Notice that Fa0/1 is a trunk port, while Fa0/2 is a static access port and has a voice VLAN assigned to it.
SwPod11# show interfaces switchport
Name: Fa0/1
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none



Name: Fa0/2
Switchport: Enabled
Administrative Mode: static access
Operational Mode: down
Administrative Trunking Encapsulation: negotiate
Negotiation of Trunking: Off
Access Mode VLAN: 110 (Data)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: 115 (Voice)

Step 5-3: Verify Router Subinterface IP Assignment

Use the show ip interface brief command to verify that the trunk is assigned correctly. This output is from Pod 11; your output will have different subinterface and IP address numbers.
RtrPod11# show ip interface brief
Interface                  IP-Address      OK? Method  Status                Protocol
FastEthernet0/0            unassigned      YES unset   up                    up
FastEthernet0/0.110        10.110.0.1      YES manual  up                    up
FastEthernet0/0.111        10.111.0.1      YES manual  up                    up
FastEthernet0/0.115        10.115.0.1      YES manual  up                    up

Task 6: DHCP Services

While phones and PCs can be assigned IP addresses statically, DHCP can automatically assign IP address leases. Additionally, DHCP can provide additional information to clients, allowing them to locate necessary resources on the network at the same time they receive an IP address. Using the router as a DHCP server is a quick way to provide DHCP services to clients.
The DHCP option 150 tells Cisco IP Phones the IP address of the TFTP server with the initial configuration file. When using CUCME, the router is the TFTP server by default. This lab assigns the default gateway IP address as the option 150 address, as there is only one way to reach the call agent in this network.

Step 6-1: Configure DHCP Pools on the Router

Always enter the ip dhcp exclude address command before a DHCP pool is created. This avoids IP addresses that should be excluded from being assigned to devices. Enter thenetwork statement as the last command in the pool. Otherwise, if devices are connected, they are assigned an IP address by DHCP right after the network statement is entered, even if the default gateway and option 150 are not configured. This can make troubleshooting difficult, as the PCs and phones will receive IP addresses, but the phones will not register and the PCs will not communicate outside their own subnet without the default router (gateway) address.
Create DHCP pools for both the data and voice networks. While it might seem that option 150 is irrelevant in data VLANs, with software on a PC able to emulate a phone (such as the Cisco IP Communicator software), it makes sense to include it for both DHCP pools.
RtrPodx(config)# ip dhcp excluded-address 10.x0.0.1 10.x0.0.10
RtrPodx(config)# ip dhcp pool Data
RtrPodx(dhcp-config)# default-router 10.x0.0.1
RtrPodx(dhcp-config)# option 150 ip 10.x0.0.1
RtrPodx(dhcp-config)# network 10.x0.0.0 255.255.255.0
RtrPodx(dhcp-config)# exit
RtrPodx(config)# ip dhcp excluded-address 10.x5.0.1 10.x5.0.10
RtrPodx(config)# ip dhcp pool Voice
RtrPodx(dhcp-config)# default-router 10.x5.0.1
RtrPodx(dhcp-config)# option 150 ip 10.x5.0.1
RtrPodx(dhcp-config)# network 10.x5.0.0 255.255.255.0
RtrPodx(dhcp-config)# exit

Task 7: Test and Cleanup

Step 7-1: Test Connectivity

Connect a PC to the switch. Verify that the PC is assigned an IP address from the 10.x0.0.0 /24 subnet. Verify that the PC can telnet to both the router and the switch management IP addresses. If not, troubleshoot the configuration.

Step 7-2: Save the Configurations

Save the configurations into a text file for both the router and switch. They will be needed for future labs.

Step 7-3: (Optional) Explore Power Over Ethernet on the Switch

If you have a switch that is PoE capable and a Cisco IP Phone or two, monitor the console port of the switch and connect the jack on the phone labeled SW to a switch port. SeeFigure 3-2 for an example.
Figure 3-2
Figure 3-2. Cisco IP Phone Connections
If you connect an older Cisco IP Phone (a 7960, for example) that supports only Cisco-proprietary inline power, you might see a message like this on the switch console line:
*Mar  1 05:23:55.900: %ILPOWER-7-DETECT: Interface Fa0/3: Power Device detected:
  Cisco PD
*Mar  1 05:23:55.976: %ILPOWER-5-POWER_GRANTED: Interface Fa0/3: Power granted
If you connect a newer Cisco IP Phone (a 7975, for example) that supports the IEEE 802.1af standard, you might see a message like this on the switch console line:
* Mar  1 05:23:55.858: %ILPOWER-7-DETECT: Interface Fa0/4: Power Device detected:
  IEEE PD
Mar  1 05:23:55.942: %ILPOWER-5-POWER_GRANTED: Interface Fa0/4: Power granted
When verifying PoE usage or troubleshooting phone power problems, you can see the existing PoE usage with the show power inline command. Knowing the remaining PoE capacity is important, as Cisco sells some switch models that do not have enough PoE to fully power all ports, such as the 24-port Catalyst 2960-24LT-L that supports only eight PoE devices at 15.4 watts.
In this output from Pod 11, there are two Cisco IP Phones attached, consuming 18.3 watts, with 351.7 watts of PoE capacity left on this switch. The 7960 phone (6.3 watts) does not have a PoE class, as it does not support 802.1af, while the 7975 phone (12.0 watts) shows as an IEEE PoE Class 3 device.
SwPod11# show power inline
Available:370.0(w)  Used:18.3(w)  Remaining:351.7(w)

Interface Admin  Oper       Power   Device              Class Max
                            (Watts)
--------- ------ ---------- ------- ------------------- ----- ----
Fa0/1     auto   off        0.0     n/a                 n/a   15.4
Fa0/2     auto   off        0.0     n/a                 n/a   15.4
Fa0/3     auto   on         6.3     IP Phone 7960       n/a   15.4
Fa0/4     auto   on         12.0    IP Phone 7975       3     15.4
Fa0/5     auto   off        0.0     n/a                 n/a   15.4
Fa0/6     auto   off        0.0     n/a                 n/a   15.4
At this point, the phones should be attempting to register and will display a message such as “Registering” or “Configuring CM List” (the message will vary depending on the phone model and the version of firmware on the phone). If the phones show “Configuring IP” for more than a few seconds, the DHCP service is not functioning. The messages displayed on the phones are useful information when troubleshooting.

Lab 3-2: Network Time Protocol

Figure 3-3
Figure 3-3. Topology Diagram
Equipment Required
This lab uses the following equipment:
  • Cisco router (and a second Cisco router if Internet access is not allowed from the first router)
  • Switch that supports voice VLANs
Learning Objectives
Upon completion of this lab, you will be able to configure Network Time Protocol (NTP).
Scenario
SOI wants its new data network to use NTP to synchronize time for network devices.
NTP is not only important for synchronizing the time in network device event logs, but also for VoIP to show the correct time on the display of the phones and record the correct timestamp on voicemails, among other uses. The best way to keep everything synchronized is to use an NTP server to coordinate time.
This lab has instructions for two options:
  • Option A assumes access to a production network that can reach an NTP server on the Internet.
  • Option B configures another Cisco router to provide NTP time to simulate an Internet NTP server.
These instructions refer to the Pod Addressing Table in Appendix A to determine the IP addresses and VLAN numbers used for your pod. Wherever an x is shown, substitute the pod number.

Task 1: NTP Services

Step 1-1: Load Prior Configurations

Use the configuration from Lab 3-1. If necessary, load the configuration for both the switch and router.

Step 1-2: (Optional) Configure Local Time Zone

NTP is calculated using UTC (Greenwich Mean Time), but you might want to see the time displayed on the router and phones using your local time zone.
RtrPodx(config)# clock timezone timezone offset-from-GMT
For example, U.S. Central Daylight Time would use clock timezone cdt -6.
RtrPodx(config)# clock summer-time zone recurring
For example, U.S. Central Daylight Time would use clock summer-time cdt recurring.

Step 1-3: Manually Set the Clock

By manually setting the clock close to the correct time, you reduce the amount of time it takes to synchronize with the NTP server. Ideally, you should be within a minute or two of the correct time.
Use the privileged EXEC mode command clock set to manually set time:
RtrPodx# clock set hh:mm:ss day month year
For example, if the current day is Thursday, August 16, 2012 and the time is 9:40 p.m., you would enter clock set 21:40:00 16 August 2012.

Step 1-4 (Option A): Contact an NTP Server on the Internet

(Proceed to Step 1-4 [Option B] if you do not have access to the Internet.)
Configure an interface on the router to reach the Internet. The commands in this step assume that Fast Ethernet 0/1 is cabled to a production network with Internet access and a DHCP server that will assign IP addresses to the router.
RtrPodx(config)# interface fastethernet 0/1
RtrPodx(config-if)# ip address dhcp
RtrPodx(config-if)# no shutdown
RtrPodx(config-if)# exit
RtrPodx(config)# ip route 0.0.0.0 0.0.0.0 gateway-of-Fa0/1-network
A list of NTP stratum two servers can be found at www.ntp.org(http://support.ntp.org/bin/view/Servers/StratumTwoTimeServers). After selecting one close to you, use the ntp server command:
RtrPodx(config)# ntp server ntp_server_IP_address
Skip Step 1-4 (Option B) and go to Step 1-5 to verify NTP operation.

Step 1-4 (Option B): Configure Another Cisco Router to Act as an NTP Server

(Skip this step if you completed Option A.)
The commands in this step assume that Fast Ethernet 0/1 on the voice router is cabled to another Cisco router. (A serial interface could also be used, but the Ethernet interfaces do not require any additional hardware.)
First, configure the other router to connect to the voice router.
Router(config)# hostname NTP_Server
NTP_Server(config)# interface fastethernet 0/0
NTP_Server(config-if)# ip address 192.168.0.1 255.255.255.0
NTP_Server(config-if)# no shutdown
NTP_Server(config-if)# exit
Set the time zones and clock on the NTP_Server router to match the VoIP router (as you did in Steps 1-2 and 1-3).
NTP_Server(config)# clock timezone timezone offset-from-GMT
NTP_Server(config)# clock summer-time zone recurring
NTP_Server# clock set hh:mm:ss day month year
Because you are configuring a “fake” NTP server, it is best to use a higher NTP stratum number to avoid conflicting with real NTP servers. Configure the NTP_Server router to be an NTP time source with the ntp master stratum number command.
NTP_Server(config)# ntp master 4
Configure the VoIP router to connect to the NTP_Server router.
RtrPodx(config)# interface fastethernet 0/1
RtrPodx(config-if)# ip address 192.168.0.2 255.255.255.0
RtrPodx(config-if)# no shutdown
RtrPodx(config-if)# exit
RtrPodx(config)# ntp server 192.168.0.1
RtrPodx(config)# end
Go to Step 1-5 to verify NTP operation.

Step 1-5: Verify That the Time Is Synchronized

Use the following commands to verify that NTP is working:
RtrPodx# show ntp status
RtrPodx# show ntp association
RtrPodx# show ntp association detail
In Examples 3-2a to 3-2g, the Pod 11 router is shown acquiring NTP time from another router. Your results will vary, but the descriptions will help you understand the various outputs you might see as the router uses NTP to synchronize.
The show ntp associations command output start with an “INIT” as the status, while theshow ntp associations detail command output shows the server as “insane, invalid, unsynced” and the filter error is 16 (showing no polling data).

Example 3-2a. Output Showing Pod 11 Router Acquiring NTP Time

RtrPod11# show ntp associations
  address         ref clock       st   when   poll reach  delay  offset   disp
 ~192.168.0.1     .INIT.          16      -     64     0  0.000   0.000 16000.
 * sys.peer, # selected, + candidate, - outlyer, x falseticker, ~ configured
RtrPod11# show ntp associations detail
192.168.0.1 configured, insane, invalid, unsynced, stratum 16
ref ID .INIT., time 00000000.00000000 (18:00:00.000 CDT Thu Dec 31 1899)
our mode client, peer mode unspec, our poll intvl 64, peer poll intvl 1024
root delay 0.00 msec, root disp 0.00, reach 0, sync dist 16.00
delay 0.00 msec, offset 0.0000 msec, dispersion 16000.00
precision 2**24, version 4
org time 00000000.00000000 (18:00:00.000 CDT Thu Dec 31 1899)
rec time 00000000.00000000 (18:00:00.000 CDT Thu Dec 31 1899)
xmt time 00000000.00000000 (18:00:00.000 CDT Thu Dec 31 1899)
filtdelay =     0.00    0.00     0.00    0.00    0.00    0.00    0.00    0.00
filtoffset =    0.00    0.00     0.00    0.00    0.00    0.00    0.00    0.00
filterror =    16.00   16.00    16.00   16.00   16.00   16.00   16.00   16.00
minpoll = 6, maxpoll = 10
After the INIT phase is done (which can take a minute), the router shows the difference between the NTP server time and the time on the router. The router is now establishing the variation in time between the received time and local time. At the point the incrementing “when” counter equals the “poll” number, the NTP server will be queried again.

Example 3-2b. Output Showing Pod 11 Router Acquiring NTP Time

RtrPod11# show ntp associations
  address         ref clock       st   when   poll reach  delay  offset   disp
 ~192.168.0.1     127.127.1.1     10     11     64     1  0.000 -348980 7937.5
 * sys.peer, # selected, + candidate, - outlyer, x falseticker, ~ configured
RtrPod11# show ntp associations
  address         ref clock       st   when   poll reach  delay  offset   disp
 ~192.168.0.1     127.127.1.1     10     44     64     1  0.000 -348980 7937.5
 * sys.peer, # selected, + candidate, - outlyer, x falseticker, ~ configured
In Example 3-2c, the router is 3,489.807 seconds off from the NTP server time. This phase will take several minutes.

Example 3-2c. Output Showing Pod 11 Router Acquiring NTP Time

RtrPod11# show ntp associations detail
192.168.0.1 configured, insane, invalid, stratum 10
ref ID 127.127.1.1   , time D22D35B2.32265329 (00:57:06.195 CDT Wed Sep 28 2011)
our mode client, peer mode server, our poll intvl 64, peer poll intvl 64
root delay 0.00 msec, root disp 0.30, reach 1, sync dist 7.94
delay 0.00 msec, offset -3489807.6733 msec, dispersion 7937.50
precision 2**24, version 4
org time D22D35B8.CB5A7071 (00:57:12.794 CDT Wed Sep 28 2011)
rec time D22D435A.9A57C7DE (01:55:22.602 CDT Wed Sep 28 2011)
xmt time D22D435A.99DE9D3F (01:55:22.601 CDT Wed Sep 28 2011)
filtdelay =     0.00    0.00    0.00    0.00    0.00    0.00    0.00    0.00
filtoffset = -3489.8    0.00    0.00    0.00    0.00    0.00    0.00    0.00
filterror =     0.00   16.00   16.00   16.00   16.00   16.00   16.00   16.00
minpoll = 6, maxpoll = 10
The next phase is to accept the time from the NTP server and establish the accuracy of the local clock. Notice that the router is just over 2 milliseconds off from the NTP server. The “filteroffset” and “filtererror” are now 0 for the first poll.

Example 3-2d. Output Showing Pod 11 Router Acquiring NTP Time

RtrPod11# show ntp associations detail
192.168.0.1 configured, insane, invalid, stratum 10
ref ID 127.127.1.1   , time D22D36A0.3225413B (01:01:04.195 CDT Wed Sep 28 2011)
our mode client, peer mode server, our poll intvl 64, peer poll intvl 64
root delay 0.00 msec, root disp 0.21, reach 1, sync dist 7.94
delay 0.00 msec, offset 2.2946 msec, dispersion 7937.50
precision 2**24, version 4
org time D22D36A0.CC349A2D (01:01:04.797 CDT Wed Sep 28 2011)
rec time D22D36A0.CBD66632 (01:01:04.796 CDT Wed Sep 28 2011)
xmt time D22D36A0.CB603CB8 (01:01:04.794 CDT Wed Sep 28 2011)
filtdelay =     0.00    0.00    0.00    0.00    0.00    0.00    0.00    0.00
filtoffset =    0.00    0.00    0.00    0.00    0.00    0.00    0.00    0.00
filterror =     0.00   16.00   16.00   16.00   16.00   16.00   16.00   16.00
minpoll = 6, maxpoll = 10
Every 64 seconds, the router polls the NTP server again. You can see the polls show up, as the “filtererror” is gradually set to 0 for each new poll.

Example 3-2e. Output Showing Pod 11 Router Acquiring NTP Time

RtrPod11# show ntp associations
192.168.0.1 configured, insane, invalid, stratum 10
ref ID 127.127.1.1   , time D22D36D2.32254796 (01:01:54.195 CDT Wed Sep 28 2011)
our mode client, peer mode server, our poll intvl 64, peer poll intvl 64
root delay 0.00 msec, root disp 0.44, reach 3, sync dist 3.94
delay 0.00 msec, offset 3.1598 msec, dispersion 3937.73
precision 2**24, version 4
org time D22D36DF.CC672189 (01:02:07.798 CDT Wed Sep 28 2011)
rec time D22D36DF.CBD02AD0 (01:02:07.796 CDT Wed Sep 28 2011)
xmt time D22D36DF.CB5A1A5B (01:02:07.794 CDT Wed Sep 28 2011)
filtdelay =     0.00    0.00    0.00    0.00    0.00    0.00    0.00    0.00
filtoffset =    0.00    0.00    0.00    0.00    0.00    0.00    0.00    0.00
filterror =     0.00    0.00   16.00   16.00   16.00   16.00   16.00   16.00
minpoll = 6, maxpoll = 10
After enough polls have been completed, the time on the router is NTP synchronized. Your router now considers the NTP server “our master, sane, and valid.”

Example 3-2f. Output Showing Pod 11 Router Acquiring NTP Time

RtrPod11# show ntp associations detail
192.168.0.1 configured, our_master, sane, valid, stratum 10                             
ref ID 127.127.1.1   , time D22D3756.32286702 (01:04:06.195 CDT Wed Sep 28 2011)
our mode client, peer mode server, our poll intvl 64, peer poll intvl 64
root delay 0.00 msec, root disp 0.39, reach 17, sync dist 0.94
delay 0.00 msec, offset 3.1598 msec, dispersion 939.24
precision 2**24, version 4
org time D22D3760.CCE2CF70 (01:04:16.800 CDT Wed Sep 28 2011)
rec time D22D3760.CBD604CE (01:04:16.796 CDT Wed Sep 28 2011)
xmt time D22D3760.CB5F51F8 (01:04:16.794 CDT Wed Sep 28 2011)
filtdelay =     0.00    0.00    0.00    0.00    0.00    0.00    0.00    0.00
filtoffset =    0.00    0.00    0.00    0.00    0.00    0.00    0.00    0.00
filterror =     0.00    0.00    0.00    0.00   16.00   16.00   16.00   16.00
minpoll = 6, maxpoll = 10
The asterisk (*) in front of the NTP server IP address shows that the server is synchronized. The show ntp status command also shows that the server is synchronized.

Example 3-2g. Output Showing Pod 11 Router Acquiring NTP Time

RtrPod11# show ntp associations
  address         ref clock       st   when   poll reach  delay  offset   disp
*~192.168.0.1     127.127.1.1     10     21     64   377  0.000  15.598  4.689
 * sys.peer, # selected, + candidate, - outlyer, x falseticker, ~ configured
RtrPod11# show ntp status
Clock is synchronized, stratum 11, reference is 192.168.0.1
nominal freq is 250.0000 Hz, actual freq is 249.9998 Hz, precision is 2**24
reference time is D22D3760.CBD604CE (01:04:16.796 CDT Wed Sep 28 2011)
clock offset is 0.0031 msec, root delay is 0.00 msec
root dispersion is 0.94 msec, peer dispersion is 0.44 msec
loopfilter state is 'CTRL' (Normal Controlled Loop), drift is 0.000000722 s/s
system poll interval is 64, last update was 99 sec ago.

Step 1-6: (Optional) Configure the Switch to Get NTP from the Router

For the sake of making sure that all networking devices are synchronized using NTP, the switch should use the router as an NTP source.
SwPodx(config)# clock timezone timezone offset-from-GMT
SwPodx(config)# clock summer-time zone recurring
SwPodx(config)# ntp server 10.x1.0.1

Step 1-7: Save the Configurations

Save the configurations into a text file for both the router and switch. They will be needed for future labs.

Lab 3-3: Phone Boot/Registration Process

Equipment Required
No equipment is required for this lab.
Learning Objectives
Upon completion of this lab, you will better understand the Cisco IP Phone boot and registration process.

Task 1: Questions

The most important part of solving problems with VoIP solutions is knowing how a properly functioning system should work and comparing it to an existing problem. Cisco IP Phones have multiple steps to complete when connected to the network, and understanding the process from booting to registration will speed resolution of problems.
Question 3.1
List at least three ways that a Cisco IP Phone can receive power.
1.___________________________________________________________________________
2.___________________________________________________________________________
3.___________________________________________________________________________
Question 3.2
What two protocols can Cisco IP Phones use to register to the Call Agent (depending on the phone firmware loaded)?
1.___________________________________________________________________________
2.___________________________________________________________________________
Question 3.3
Number the following steps in the order they occur during the phone boot process:
___ The phone downloads the configuration file from the TFTP server.
___ The phone gets IP address information from DHCP, including option 150.
___ The phone registers with one or more Call Agents.
___ The phone receives power, which might involve receiving PoE from the switch.
___ The phone learns the VLAN information from CDP.

info copy by:CISCOPRESS

Ajudem nos a melhorar o nosso blog: